Longitude corner points reversed by vtmap

Maplorer for WinCE GPS and other moving map software

Longitude corner points reversed by vtmap

Postby maplorer » Wed Jul 03, 2013 9:05 pm

I've finally got the GPS working with Maplorer in my YF International 82F (Dealextreme sku 39243 PNA.

However when following a track, I noticed that as I moved left and up screen, my track moved up and right. It also showed my present position wrong on startup, though the raw GPS position data was correct.

So I reversed the Longitude numbers (TR to BL) in the .ini file and everything worked fine. I live in the northeast US, and my Longitude numbers are negative, perhaps there is a simple "sign" mistake in your screen movement direction algorithm?

Anyway, thanks for a great program, I'm really enjoying it for walking around my 67 acres of woods using satellite images to see where I am.
maplorer
Site Admin
 
Posts: 72
Joined: Mon Jul 01, 2013 2:44 pm

Re: Longitude corner points reversed by vtmap

Postby maplorer » Wed Jul 03, 2013 9:06 pm

Well, apparently the 9600 baud rate worked but wasn't ideal. My final com settings for this GPS are:

4800 Baud
1 stop bit
no parity

It works great after the corner coordinates were switched (see my last note). Having great fun with satellite image maps!
maplorer
Site Admin
 
Posts: 72
Joined: Mon Jul 01, 2013 2:44 pm

Re: Longitude corner points reversed by vtmap

Postby maplorer » Wed Jul 03, 2013 9:06 pm

vtmap wrote:
Well, apparently the 9600 baud rate worked but wasn't ideal. My final com settings for this GPS are:

4800 Baud
1 stop bit
no parity

It works great after the corner coordinates were switched (see my last note). Having great fun with satellite image maps!


Big THANKS for the update and the report about the corner inversion - you may be right, I never moved that far west :-)

Its good to know it can be solved by simply swapping the coordinates, but I'll look into one of these days...
maplorer
Site Admin
 
Posts: 72
Joined: Mon Jul 01, 2013 2:44 pm

Re: Longitude corner points reversed by vtmap

Postby maplorer » Wed Jul 03, 2013 9:06 pm

This bug is now fixed. A new version is available at
http://www.maplorer.com/maplorer.html

The inversion concerned also north and south - it would be realy great if someone from Australia or New Zealand could test this!

Western (Americas, ...) and Southern coordinates (Australia) must be given as negative in the POS files.

Thanks again for reporting the problem.


vtmap wrote:

However when following a track, I noticed that as I moved left and up screen, my track moved up and right. It also showed my present position wrong on startup, though the raw GPS position data was correct.

So I reversed the Longitude numbers (TR to BL) in the .ini file and everything worked fine. I live in the northeast US, and my Longitude numbers are negative, perhaps there is a simple "sign" mistake in your screen movement direction algorithm?
maplorer
Site Admin
 
Posts: 72
Joined: Mon Jul 01, 2013 2:44 pm


Return to Moving map software for GPS systems and cell phones

Who is online

Users browsing this forum: No registered users and 2 guests

cron